Pro Subscription not Working

Firstly, thanks for your pro support.

There are three common reasons why Flowx is not finding your pro subscription:

  1. You have multiple Google accounts on your device and Google Play is looking in the wrong account.
  2. The Google Play cache is not up-to-date.
  3. Your pro subscription has expired.

You can see more details about these common causes below. If none of these appear to be the cause, please email me the debug log.

1. Multiple Google Play Accounts

Google has a policy that only checks one Google account (the primary one) on your phone for pro purchases. If you have multiple accounts on your phone, Google Play may be checking the wrong account for your Flowx purchase.

This issue has been discussed to death since 2016 here: Play Billing Issues. Unfortunately, Google doesn't seem to be addressing this.

Go to Android Settings > Accounts > Google to check how many Google accounts you have on your phone.

If you do have multiple accounts that is causing this problem, you can follow the instructions given by a Flowx user with two Google accounts:

  1. Delete the Flowx app
  2. Remove the business account (I bought the subscription with my private one)
  3. Clear app data and cache from the Google play app and the Google play services
  4. Reinstall flowx with the right account
  5. Restart phone
  6. Add back the business account

Sorry about this problem. I would rather not have it but I cannot do much about it.

2. Google Play Cache

In extremely rare cases, the Google Play cache does not update after you've made a purchase, especially if you purchased on one device and checked on another device. Usually this problem fixes itself within 24 hours.

There are other fixes if you search the internet but it's not clear which one works and it's sometimes easier to wait a few hours.

3. Pro Subscription has Expired

Check the email Google sent your for the original purchase and see f your subscription has expired. You can also check on the Google Play Store website or app.

If you can't find anything, email me the debug log from the app and I can check.